Sysax Product Forums / Sysax Multi Server / Bugs and Feature Requests / Sysax multiserver - Active Directory Authentication
Posted:  06 Nov 2008 13:02
Hi, I've downloaded the trial version of your Multiserver product, and I'm attempting to perform eval of its SSH2/SFTP functionality.
    1. I've setup the authentication for Active Directory/Ldap and specified the Active Directory domain controller and port number of 389.
    2. I've connected to the SSH server using the WinSCP client and attempted to authenticate using a domain account and password. This fails whether I use the formats username, Domain\username or the UPN username@domain....
    3. I was hoping you could clarify if AD authentication is enabled in your trial software. The domain controller and the server hosting Multiserver and both running Windows 2003 SP2.
    4. The Multiserver logs reports - "rejected - LDAP Active Directory authentication failed". I've verified that the account's password is correct and that it is not disabled or locked out.
Local windows authentication works fine.
Best Wishes,
Posted:  06 Nov 2008 13:05   Last Edited By: sysaxsupport
It appears that there may be an issue with binding to the active directory controller in some cases.
You can download a debug version of the main executable program
After unzipping the file,
    1. Make any changes using the control panel in the current installation of Sysax Multi server and save it.
    2. Make sure that Sysax Multi server is stopped..
    3. Copy sysaxservd.dbg.exe to any folder
    4. Open the dos command prompt, navigate to this folder and type in sysaxservd.dbg.exe /debug. This will start the server and a debug file that ends in _debuglog.txt will be created in the same folder
    5. Try to connect to the server (assuming that you have already setup for LDAP authentication) using username, Domain\username and UPN
    6. Stop the server by typing in control-C in the dos command prompt.
    7. Send us the Oct_20_2008_09_01_45_debuglog.txt file.
You do not have to touch the existing installation. Please also let us know if Active directory authentication is now working with this debug version.
Posted:  06 Nov 2008 13:09
Thank you for the quick response and I regret that I could not be equally quick in my reply. I've carried out the procedure and attached the debug log as requested. I attempted the following authentications in order:
    Username only - tried this twice and both attempts failed
    Domainusername - this worked!
    UPN - tried this twice and both attempts failed.
Please note that in the attached debug log I've had to obsfucate my company name in the FQDNs with Hope this does not cause you a problem.
Best Wishes
Posted:  06 Nov 2008 13:12   Last Edited By: sysaxsupport
I have another debug version of the main executable program. This should support Active directory authentication using username, domainusername, or upn. Please send us the debug log file. If this is successful for you, we can get you a release version of the Server.
Posted:  06 Nov 2008 13:16
I've tried the new debug version and it appears to work for all logins. I connected using username then domainusername then UPN. I then repeated this. And I've attached the debug log.
I did note that the server running Sysax hung at 100% utilization for a couple of minutes after I closed the Winscp connection using the UPN.
However I could not reproduce this behaviour the second time around. This may have been a one-off unrelated event.
Best Wishes
Posted:  06 Nov 2008 13:17   Last Edited By: sysaxsupport
Thank you for providing us the debugging information. You can download a full release
You will need to uninstall the current version before installing the new version.

Copyright © 2021 Codeorigin, LLC - All Rights Reserved.
XML RSS 2.0 XML Atom 1.0