Sysax Product Forums / Sysax Multi Server / Bugs and Feature Requests / Problem in Porduct Evaluation
Posted:  06 Nov 2008 13:15
In evaluation mode, the script seems to stop at the change direcotory level
Could you please tell me what's wrong with it

# Script name: FTP_GET_TEST.fscr
ftpconnect "", 21, "ftpTest", "ftpTest";
settransfertype ascii;
ftpsetpath remote, "To_Lux";
ftpgetlist remote, @remote_list;
foreach $remote_list_item in @remote_list begin
print $;

Executing script C:\Home\Sysax\FTP_GET_TEST.fscr
Script Engine: Line 4: Executing ftpconnect. Parameter(s): "" 21 "ftpTest" (not displayed)
Script Engine: Line 5: Executing settransfertype. Parameter(s): ascii
Script Engine: Line 6: Executing ftpsetpath. Parameter(s): remote "To_Lux"
CWD /To_Lux
Posted:  06 Nov 2008 13:17
It looks like the script never established a connection with the remote server. Please doublecheck the IP address of the server that is specified in the script and if you are able to manually connect to the server from this computer. You can use the following to check if a connection was successfully established, from within the script, after the ftpconnect command:

if success ne ftpresult begin
print "Could not connect to server";
Posted:  06 Nov 2008 13:20
You brought my attention in the right direction
My problem is solved, it works now fine

Copyright © 2021 Codeorigin, LLC - All Rights Reserved.
XML RSS 2.0 XML Atom 1.0