Sysax Product Forums / Sysax Multi Server / Bugs and Feature Requests / SSH Public Key Authentication
Posted:  07 Nov 2008 10:59
When adding a Public Key Auth key,
To the Shell Server it makes no difference to the connection I can merely connect from any machine as long as the username and password are correct. I have tried everything to get this to work. I can not find any documentation on your website regarding this feature.
How can I ensure that this is working.
Thanks for your help in advance
Posted:  07 Nov 2008 11:01
When you set up public key authentication, it does not prevent you from logging in using a password. Rather, it allows you the option to also connect using your key instead of a password.
Posted:  07 Nov 2008 11:03
We have already tried this also. No keypairs work at all-we have tried RSA and DSA of differing lengths and none of them work.We have used both Bitvise Tunnelier and WSFTPpro and none of them allow access with exchanging keys. The logs merely state that the password is incorrect. Why is the renodocumentation on this on this site or your othersite.?
There is also no way of knowing if it actually doing anything-you can putarandom text file in as the SSH key and the application does not even complain.There is no feedback at all. What do you suggest?
Posted:  07 Nov 2008 11:04
Assuming that you are pointing to a valid public key file for the account, I would look at how you generate the key pairs. The public key must be in openssh format.
What tool are you using to generate the key pair?
Yes, the error reporting needs to be improved for handling pub key authentication. The documentation is being updated and will be released along with the final release at the end of April.
Posted:  13 Dec 2011 18:17
I actually had the same problem, resolved it by using the configuration in the tool instead of using the web gui for pointing to my public key file
Posted:  20 Apr 2012 22:43
Same deal, problem with the key exchange. Key is in OpenSSH format.

04/20/2012 01:47:16 PM: [NOTE] SFTP Connection ( logged into account tatem (Auth: PublicKey -> C:\Authentication\SSH\Tatem\
04/20/2012 01:47:16 PM: [FAIL] An error occured during key exchange Serv auth req
04/20/2012 01:47:16 PM: [NOTE] Connection from disconnected

Set up via web admin, I'll try the server-side config.
Posted:  20 Apr 2012 22:51
Still fails.
Client is GUI SFTP, v.6.0.4 on Windows 7

Client-side log:

[Apr 20 13:47:49] 1002 Algorithm_negotiation_success, "kex_algorithm=diffie-hellman-group1-sha1, hostkey_algorithm=ssh-dss, cipher=aes192-cbc/aes192-cbc, mac=hmac-sha1/hmac-sha1, compression=none/none", Session-Id: 46
[Apr 20 13:47:49] 1003 KEX_success, Session-Id: 46, Protocol-session-Id: 791081310B8964A54E50604B770DF3F148FBB45D
[Apr 20 13:47:49] 703 Auth_methods_available, Auth methods: publickey,password, Session-Id: 46
[Apr 20 13:47:49] 1210 Key_store_sign, Key path: software://0/directory_key(C:\Users\TATEM.AUTHCALDOJNET\Application Data\SSH\UserKeys\tatem-caldoj)/key_id(3), Session-Id: 46
[Apr 20 13:47:49] 6209 Broker_connection_connect_failed, Dst: cadojftpsvr02, Dst Port: 22, Local username: tatem, Remote username: tatem, Uses gateway?: Yes, Session-Id: 46, "Protocol error, disconnecting, remote disconnect"
[Apr 20 13:47:49] 6005 Broker_exec_channel_open_failed, Client: ssh-client-g3, Pid: 5824, Server: cadojftpsvr02, Server Port: 22, Remote username: tatem, Local username: tatem, Command: sftp, "Terminal width: 80 chars, Terminal height: 24 rows, Terminal width: 640 pixels, Terminal height: 480 pixels, Stderr type: sink, Is subsystem?: TRUE, Allocate pty?: FALSE, X11 forwarding?: retain, Agent forwarding?: retain, X11 Display Variable: (null), Agent variable: (null), Term variable: vt100", Channel Id: 0, "Protocol error

Copyright © 2021 Codeorigin, LLC - All Rights Reserved.
XML RSS 2.0 XML Atom 1.0