Sysax Product Forums / Sysax Multi Server / Bugs and Feature Requests / Sysax Auto hanging when switching modes
Posted:  07 Nov 2008 12:04
Every time I connect to a remote site with FTPS, the script hangs when switching to binary mode
Posted:  07 Nov 2008 12:06
Have you tried using non-secure mode, rather than secure? Does the remote site use a firewall of some kind?
Posted:  07 Nov 2008 12:08
The remote site might use some type of firewall but they do
allow access on port 21 (the site is
Unfortunately, due to the content of the files we're sending we have to
follow HIPAA standards, so the connection _has_ to be FTPS. The site works with another regular

ftp client; we currently manually transfer the files over.
Have you tried using non-secure mode, rather than secure? Does the
remote site use a firewall of some kind?

An update on this issue:
The connection works properly, and the script returns error code 0 when
manually ran, but if I schedule the script it doesn't finish properly.
It has an error when changing my local path to a network drive, even
though it works when I manually do it.
Also, once we get this up and going I'd like some info on purchasing
your enterprise license as well
Posted:  07 Nov 2008 12:11
Based on what you are saying, if you can change into the network drive when running manually,

but cannot do so when running using the scheduler, it looks like the network resource is only

available to a specific user account. The scheduler runs as a windows service and in your case,

it looks like you have to be logged in as a specific user to access the network resource.
Are you able to run your script from the command using:

sysaxftp -script myscript.fscr -log myscriptlog.txt
Posted:  07 Nov 2008 12:13   Last Edited By: sysaxsupport
Alright, I schedulesd the job on the windows scheduler instead of the
Sysax service and it worked just fine.
We're interested in purchasing the enterprise license for this. How do I
go about doing that? Do you do PO #?
Posted:  07 Nov 2008 12:15   Last Edited By: sysaxsupport
I can ask the sales team to send you an initial invoice if you need it. You can make the actual

purchase online from the website.
Posted:  07 Nov 2008 12:17   Last Edited By: sysaxsupport
An invoice would be ideal

Also, how do you timestamp a filename?
Say, I have 3 files I zip before I upload to a site, if I want that zip file to be named

can you zip multiple files? Without zipping a whole
Posted:  07 Nov 2008 12:20   Last Edited By: sysaxsupport
Generation of the timestamp can be done using the gettimestamp command. You can get the

timestamp for the current date or any day before or after. The strslice and strprint commands

can be used to manipulate the format of the timestamp. This generated filename can then be

passed to the ftpcompress command to generate the zip file with the timestamp.
Here is some example code:

#get the timestamp in YYYYMMDDhhmmss format
gettimestamp ~mytimestamp;

#get only the month and day and hour
strslice ~mytimestamp, left, 4, 6;

#generate the file name
strprint ~myfilename, ~mytimestamp, ".zip";

#print out the generated file name
print ~myfilename;

#use the file name in the ftpcompress command
ftpcompress "rawfile.txt", ~myfilename;

I am assuming that you are asking about placing multiple files into one zip file. Currently the

way to do this is to create a temporary folder, copy the files to this folder, compress the

folder, and then delete the temporary folder and its contents.
Posted:  07 Nov 2008 12:24   Last Edited By: sysaxsupport
Is there a contact number that I can contact support at?
I said it worked too early - The filename is ending up as
Here's what I have so far:

gettimestamp ~timestamp; # generate current timestamp
strslice ~timestamp, left, 0, 8; #extract 8 chars starting from left
strprint ~remotepath, "";
strprint ~localpath, "TataintrfaceHealthprodapps";
strprint ~localname, ~timestamp, ".zip";
print ~localname;
setduperules bysize, rename, skip, rename, ".bk";
ftpconnectssl("", 21, "user", "passwd";
ftpsetpath local, ~localpath;
ftpsetpath remote, ~remotepath;
ftpgetlist local, @local_list;
#ftpgetlist remote, @remote_list;
ftpcompress "gilsbadn.txt", ~localname;

We have, 3 files being copied to a folder from another script, all with
static names. We need the 3 files zipped, with a timestamp, and sent to
the remote site. So far, zip file is not being saved as, but as whatever
rawfile I compress. ftpmakefolder, ftpdelete and ftpmovelocal is what I want for the zipping
of the files right?
Posted:  07 Nov 2008 12:28
I can have someone from tech support call you if you give use a telephone number to reach you.
Technical support is typically handled by email. We do provide phone support when needed - the

tech support person initiates the call.
Can you send a copy of the output log file? From this line in your script,
strprint ~localpath, "TataintrfaceHealthprodapps";

it looks like there may be other path related issues. For example, there needs to be two

backslashes for the path (one of them server as the escape character)
Posted:  07 Nov 2008 12:34   Last Edited By: sysaxsupport
Our developers have a product update with the fix for this issue

You can install this version to continue with your evaluation. This fix will also be available in the public release which scheduled later in the week.

Copyright © 2021 Codeorigin, LLC - All Rights Reserved.
XML RSS 2.0 XML Atom 1.0