Sysax Product Forums / Sysax Multi Server / Bugs and Feature Requests / No connection from an solaris server
Posted:  07 Nov 2008 12:19
we have bought your product Sysax Multiserver Pro to implement a ssh/sftp connection from an solaris server to the Syssax MultiServer on Windows 2003. But the connection fails! In the Syssax log I can see this error:
[FAIL] An error occured during key exchange Serv K 2 unknown type

The solaris Version is SunOS 5.8

The way we tried to connect from the Solaris server was:
FFZJ0WQ1:dcs:/drecom/dcs)> ssh ffz00yv9
Authentication successful.
Last login: Tue Jul 08 2008 12:36:50 +0200 from
Sun Microsystems Inc. SunOS 5.8 Generic Patch October 2001
No mail.
FFZ00YV9:dcs:/drecom/dcs)> sftp -v Allianz@
SshFileCopy/sshfilecopy.c:678: Making local connection.
SshFileXferClient/sshfilexferc.c:1401: ext_name `', data:
00000000: 0a .
SshFileXferClient/sshfilexferc.c:1401: ext_name `', data:
00000000: 0000 0012 ....
SshFileXferClient/sshfilexferc.c:1426: Negotiated version: 3 (own version: 3, remote version: 3).
SshFileCopy/sshfilecopy.c:619: Connection to local, ready to serve requests.
Sftp2/sftp2.c:450: Connection ready.
SshReadLine/sshreadline.c:2336: Initializing ReadLine...
SshFileCopy/sshfilecopy.c:697: Connecting to remote host. (host = Allianz@, user = NULL, port = NULL)
argv[0] = /usr/bin/ssh2
argv[1] = -v
argv[2] = -x
argv[3] = -a
argv[4] = -opasswordprompt=%U@%H's password:
argv[5] = -oauthenticationnotify=yes
argv[6] = Allianz@
argv[7] = -s
argv[8] = sftp
SshSigChld/sshsigchld.c:332: Registering handler for pid 2717.
SshSigChld/sshsigchld.c:332: Registering handler for pid 2717.
debug: SshConfig/sshconfig.c:3006: Metaconfig parsing stopped at line 3.
debug: SshConfig/sshconfig.c:826: Setting variable 'VerboseMode' to 'FALSE'.
debug: SshConfig/sshconfig.c:3309: Read 24 params from config file.
debug: SshUnixUserFiles/sshunixuserfiles.c:414: User config file not found, using defaults. (Looked for '/drecom/dcs/.ssh2/ssh2_config')
debug: Connecting to, port 22... (SOCKS not used)
debug: Ssh2Transport/trcommon.c:3823: My version: SSH-2.0-ReflectionForSecureIT_6.1.0.16
debug: client supports 1 auth methods: 'publickey'
debug: Ssh2Common/sshcommon.c:497: local ip =, local port = 44360
debug: Ssh2Common/sshcommon.c:499: remote ip =, remote port = 22
debug: SshConnection/sshconn.c:1975: Wrapping...
debug: Ssh2/ssh2.c:913: Opening /dev/tty for queries.
debug: SshReadLine/sshreadline.c:2336: Initializing ReadLine...
debug: Remote version: SSH-2.0-SysaxSSH_1.0
debug: Ssh2Transport/trcommon.c:1422: lang s to c: `', lang c to s: `'
debug: Ssh2Transport/trcommon.c:1488: c_to_s: cipher aes128-ctr, mac hmac-sha1, compression none
debug: Ssh2Transport/trcommon.c:1491: s_to_c: cipher aes128-ctr, mac hmac-sha1, compression none
debug: Ssh2Common/sshcommon.c:98: DISCONNECT received: disconnecting
debug: SshReadLine/sshreadline.c:2395: Uninitializing ReadLine...
debug: Ssh2/ssh2.c:691: Returning user input stream to original values.
Sftp2/sftp2.c:3896: buffer: 'AUTHENTICATED NO
SshReadLine/sshreadline.c:2395: Uninitializing ReadLine...
FATAL: ssh2 client failed to authenticate. (or you have too old ssh2 installed, check with ssh2 -V)
FFZ00YV9:dcs:/drecom/dcs)> warning: Authentication failed.
Disconnected; protocol error (disconnecting).
debug: Ssh2Common/sshcommon.c:585: Destroying SshCommon object.
debug: SshConnection/sshconn.c:2027: Destroying SshConn object.

It's very important for us that this problem will be solved very soon.

Thank you and with best regards,
Posted:  07 Nov 2008 12:23
Are you running the latest version of Sysax Multi Server downloaded from our website?
Also, what is the sftp software that you are using on the solaris machine? Our customers typically have used openssh, but in you case it looks like you are using a different sftp client?
Posted:  07 Nov 2008 12:25
Thank you for repply. The version I have installed was the current last version of Sysax Multi Server.
We haven't got a special sftp client. We use the sftp command from the ssh shell SSH-2.0-ReflectionForSecureIT_6.1.0.16.
Posted:  07 Nov 2008 12:29
Our team has tested connecting with the default sftp client on solaris. Is it possible to ship you a debug version of the product so that you can send us the log output?
Posted:  07 Nov 2008 12:32
yes, it is.
Posted:  07 Nov 2008 12:34   Last Edited By: sysaxsupport
A debug version of the server daemon is avalable for download
After extracting the executable, please rename the original sysaxservd.exe in the installation program and copy over this debug program. Then start the server as usual and connect using the client that you are having problems with. After duplicating the problem, please send us the following files:
- The debug log files (should be in the c:\windows\system32 folder as Jun_24_2008_22_03_42_debuglog.txt and Jun_24_2008_22_03_42_debugdump.txt)
- The sysax server log in the logs subfolder (eg. C:\Documents and Settings\All Users\Application Data\Codeorigin\SysaxServer\logs\sysaxservd.log)

Copyright © 2021 Codeorigin, LLC - All Rights Reserved.
XML RSS 2.0 XML Atom 1.0