Sysax Product Forums / Sysax FTP Automation / Bugs and Feature Requests / ftpconnectssl hangs at connect when scripted, "invalid command" at interactive prompt
Posted:  02 Feb 2010 19:58
I'm trying to set up a relatively simple script for pulling data from an ftps server, but I'm not able to get past square one with sysaxftp scripting.

I have verified connectivity, username and password from SmartFTP, also from a linux box with lftp command-line.

If I run sysaxftp from the command line, and enter the ftpconnectssl command there, I get
"ftpconnectssl is an invalid command"

If I try the following basic script:

ftpconnectsslc "", 990, "username", "password";
if ftpresult eq success begin
    print "Connected to ftps server!";
end else begin
    print "Failed to connect to ftps server!";

I've put example values in for hostname, username and password -- the script does indeed have the real values. 

If I run this with sysaxftp -script scriptname.txt then I get

FREE personal edition (non-commercial license) Personal edition license, sales@s 1 user license
Script Engine: Line 1: Executing ftpconnectssl. Parameter(s):  ""
990  "my_username"  (not displayed)

And it never comes back -- never prints the success or error output, and doesn't exit.

I have tried putting enablepasv; in before the ftpconnectssl, and I've tried using ftpconnectsslc, and each time it behaves the same way.

Is there a way to enable more detailed debug output to help me troubleshoot this?
Posted:  06 Feb 2010 00:51
It looks like you are connecting to an FTPS site that is using implicit SSL. You need to use the ftpconnectssli command for connecting to this site.

Copyright © 2021 Codeorigin, LLC - All Rights Reserved.
XML RSS 2.0 XML Atom 1.0